ipython0.11.dev and RC1

Jul 12, 2011 at 5:43 PM
Edited Jul 12, 2011 at 5:46 PM

I have PTVS RC1 and latest ipython dev version ipython-ipython-dev-0.11-2073-g002a480 installed. but still get Error using selected REPL back-end:
IPython mode requires IPython 0.11 or later. Using standard backend instead

Does RC1 work with ipython 0.11?

Coordinator
Jul 14, 2011 at 4:15 PM

Yes but you'll need to make sure you have a recent version of zmq installed (you can easy_install pyzmq) as IPython requires it.

Jul 14, 2011 at 6:35 PM
dinov wrote:

Yes but you'll need to make sure you have a recent version of zmq installed (you can easy_install pyzmq) as IPython requires it.


@dinov, Thanks. Now I can use ipython as interactive mode for python2.7/2.6 in RC1. How can I use it with ironpython2.7? when using ironpython 2.7 in RC1 with ipython mode, I got  Error using selected REPL back-end: IPython mode requires IPython 0.11 or later. Using standard backend instead.  But no error for python 2.7. Thanks for your help.

Coordinator
Jul 14, 2011 at 7:04 PM

I dont believe IPython works with IronPython... only CPython - this is an IPython limitation.  I believe with their re-architecture work in the new version they had plans for IronPython support, but i doubt if they'll do it unless ppl start asking for it...