ptvsd should bail out if python version not supported


Closed May 14, 2014 at 10:24 PM by pminaev
No way to fix.


pminaev wrote May 14, 2014 at 10:23 PM

Our ability to do so is unfortunately limited because we cannot intercept parsing errors, since our code doesn't even run until it's parsed. This, in particular, means that we cannot really do anything about 2.4 and below, because we use finally heavily in our code, and it's a new keyword in 2.5+ - so our code doesn't even parse correctly on 2.4.