6
Vote

Support debugging GAE SDK 1.7.6

description

comments

cprcrack wrote Jul 30, 2013 at 12:30 PM

Exactly, debugging for GAE with the new dev_appserver doesn't work. If you could officially support development for GAE it would be great.

fd97207 wrote Sep 21, 2013 at 7:29 PM

+1 to cpcrack. This is a big pain point. I am developing GAE app and cannot use PTVS for debugging. No breakpoints are hit.

fd97207 wrote Sep 21, 2013 at 8:10 PM

I checked I am using 1.7.5 and still can't get debugging to work.
C:\Program Files (x86)\Google\google_appengine>type version
release: "1.7.5"
timestamp: 1357690550
api_versions: ['1']

C:\Program Files (x86)\Google\google_appengine>dir old_dev*.py
Volume in drive C has no label.
Volume Serial Number is BA56-4174

Directory of C:\Program Files (x86)\Google\google_appengine

File Not Found

C:\Program Files (x86)\Google\google_appengine>dir dev*.py
Volume in drive C has no label.
Volume Serial Number is BA56-4174

Directory of C:\Program Files (x86)\Google\google_appengine

02/07/2013 07:35 PM 4,227 devappserver2.py
02/07/2013 07:35 PM 5,065 dev_appserver.py
           2 File(s)          9,292 bytes
           0 Dir(s)  236,971,888,640 bytes free

fd97207 wrote Sep 21, 2013 at 8:57 PM

FYI there is no problem debugging with PyCharm. Breakpoints are hit.

Ptools wrote Sep 21, 2013 at 9:28 PM

The main issue is that PTVS does not support debugging GAE. So this is not surprising.

We used to support the old version until GAE changed and per their own admission, broke all debuggers. We haven't gone back to implement support for their new versions.

Meanwhile, for the old SDK, here's an unlisted video that walks you thru the steps to get it working (some minor changes as this is the previous release of PTVS):

http://www.youtube.com/watch?v=-PcrSD1AwwQ

joeSchr wrote Jul 11 at 12:47 PM

Could you maybe start to support it again? Would be really helpful, thx!

joeSchr wrote Jul 11 at 5:27 PM

I got it finally running with GAE: http://goo.gl/vdOjCr

pminaev wrote Jul 11 at 5:46 PM

Thanks, Joe! This is awesome!

Ptools wrote Jul 11 at 7:00 PM

yes, thanks joe. if you'd like to contribute a doc page for for GAE we'd be delighted ;)

joeSchr wrote Jul 11 at 8:05 PM

I would, but I can't, respectively I think I'm not allowed to edit pages here.
But it's almost the same as the remote debugging article, just the arguments for the server weren't documented for the current version. at least nowhere I could find them...