DB Refresh never completes

Mar 19, 2015 at 11:49 AM
Edited Mar 19, 2015 at 12:13 PM
Hi,

I updated my Anaconda python packages and now VS wants to refresh the completion DB. The problem is that it never completes the refreshing. It starts the process, it proceeds to a certain point and then just stops and I need to restart it again.

My environment:
Environments: 
    Microsoft.PythonTools.Interpreter.ConfigurablePythonInterpreterFactoryProvider
    Microsoft.PythonTools.Interpreter.CPythonInterpreterFactoryProvider
        Id: 2af0f10d-7135-4994-9156-5d01c9c11b7e
        Factory: Python 3.4
        Version: 3.4
        Arch: X86
        Prefix Path: C:\Anaconda3
        Path: C:\Anaconda3\python.exe
        Windows Path: C:\Anaconda3\pythonw.exe
        Lib Path: C:\Anaconda3\lib
        Path Env: PYTHONPATH
Is there an email where I can send the full diagnostic info?

Some errors show up, but i don't know what to make of them:
2015-03-19T11:27:51: [WARNING] Errors
Traceback (most recent call last):
  File "C:\Program Files\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Microsoft\Python Tools for Visual Studio\2.1\ExtensionScraper.py", line 43, in <module>
    __import__(mod_name)
ImportError: DLL load failed: The specified module could not be found.
2015-03-19T11:27:51: [ERROR] Failed to scrape dde (Exit code: 1)
2015-03-19T11:27:51: Scraping win32ui
2015-03-19T11:27:51: Command: C:\Anaconda3\python.exe "C:\Program Files\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Microsoft\Python Tools for Visual Studio\2.1\ExtensionScraper.py" scrape win32ui C:\Anaconda3\lib\site-packages\Pythonwin "C:\Users\user_name\AppData\Local\Python Tools\CompletionDB\12.0\2af0f10d-7135-4994-9156-5d01c9c11b7e\3.4\site-packages_Pythonwin\win32ui"
2015-03-19T11:27:52: Output
__import__("win32ui")
2015-03-19T11:27:52: [WARNING] Errors
Traceback (most recent call last):
  File "C:\Program Files\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Microsoft\Python Tools for Visual Studio\2.1\ExtensionScraper.py", line 43, in <module>
    __import__(mod_name)
ImportError: DLL load failed: The specified module could not be found.
2015-03-19T11:27:52: [ERROR] Failed to scrape win32ui (Exit code: 1)
2015-03-19T11:27:52: Scraping win32uiole
Mar 23, 2015 at 11:43 AM
I installed PTVS 2.2 beta and now everything works fine again.
Coordinator
Mar 23, 2015 at 4:56 PM
Good to hear! Thanks