This project has moved and is read-only. For the latest updates, please go here.

azure batch app

Feb 7, 2015 at 1:17 PM
I am on Win7, 64bit and I try to build the Azure Batch App for Blender, based on :
It tells me to install
Visual Studio (done)
Microsoft Azure Batch Apps Cloud SDK (done)
Python Tools for Visual Studio (done)
Azure Batch Apps Python Client and it's required packages (Problem)

After doing the first three steps, I tried a build and it gives errors:
Could not resolve this reference. Could not locate the assembly "Microsoft.Azure.Batch.Apps.Cloud"...

So I tried to do the last step, based on:
which tells me to
pip install azure-batch-apps
but when I do that in the VS Python3.4 command shell I get:
name 'pip' is not defined

I tried doing it from the PythonShell directly which kind of worked (I had to call from WinCommandShell py -m pip install...) but still the Azure package is not found during build in VS.

What could be the problem with pip?
Feb 7, 2015 at 5:36 PM
pip is meant to be used from a regular command prompt and not within Python, and when you run it from a command prompt it may not run with the correct version of Python if you have multiple versions installed.

In my opinion (which is shared by some of the pip developers), the best way to call it is to do what you did: py -m pip install .... However, if you have Python 2.7 installed, it will use that version by default. To ensure you're using 3.4, you should write py -3.4 -m pip install .... (If you don't have any other Python versions installed then you can ignore this suggestion.)

There is also a second step to copy the libraries into the Blender directory. Did you do that?

As for the .NET issue, I'd recommend asking on the Azure Batch site that you linked. They are a separate team from the PTVS team, and will be better able to help you with their product.
Feb 8, 2015 at 6:22 PM
Hi Zooba

Thanks for your answer.

As I have no 2.7 installation of Python the pip already worked (and on re-run told me so), so I think the build problem has to be somewhere else (I opend a thread on the Azure Batch forum).
Regarding the second step: I did that, and the addon is available in blender, but needs information about the batch-process, that I obviously can't provide, as I couldn't create it.

Thanks for the help and bye.