This project has moved and is read-only. For the latest updates, please go here.

No intellisense for Tkinter

Dec 1, 2014 at 1:35 PM
Edited Dec 1, 2014 at 1:36 PM
Hello guys,

when trying to use Tkinter in VS it doesn't seem to recognize the existence of the module and no intellisense will be available. When looking through other modules there usually was a file which is missing for Tkinter. I'm currently using Anaconda but neither Anaconda nor the default Python seem to have an init file in the lib-tk folder. Tkinter still works but having intellisense would be nice as well and I wonder if there is a possibility to fix this problem. Google didn't help either so I hope this is the right place to ask this question.

Thanks in advance.
Dec 1, 2014 at 4:29 PM
It looks like we missed this in our testing (FWIW, it looks like Python 3 moved tkinter into a different folder so it will work fine).

Python 2.7 adds some default paths for searching (including lib-tk and plat-win) that we don't currently detect. Issue 1286 will resolve this eventually. Until then, if you add the lib-tk folder as a Search Path in your projects then you should get good IntelliSense for it.
Dec 1, 2014 at 5:33 PM
Edited Dec 1, 2014 at 5:36 PM
Thanks a lot for your fast response!
I will surely try it out.

Edit: Tried it out and it worked wonderfully, thanks again!