[Resolved] Intellisense does not refresh installed ibPy package.

Nov 5, 2014 at 9:21 PM
Hi,

I try to install libary IbPy. It seems to run, but for some reason the intellisense does not pick it up. I did do a refresh dB. I am running Python 2.7.

This is what I get through the Package Manager:

J.
PM> easy_install ibpy
Searching for ibpy
Best match: ibpy 0.7.6-9.51
Adding ibpy 0.7.6-9.51 to easy-install.pth file

Using c:\python27\lib\site-packages
Processing dependencies for ibpy
Finished processing dependencies for ibpy
I get no intellisense for:
from ib.ext.Contract import Contract
from ib.ext.Order import Order
from ib.opt import Connection, message
Nov 9, 2014 at 8:11 PM
I resolved it by placing all in the ib folder (run the install on setup file again).
Coordinator
Nov 10, 2014 at 3:03 PM
Does that mean it didn't install properly the first time?

We may have failed to parse the easy-install.pth file correctly the first time. These files are meant to be directory names only, but people often put arbitrary Python code in them and we can't parse that.