Can't install PTVS on VS 2013 Express for Desktop

Jun 24 at 10:19 PM
Edited Jun 24 at 10:25 PM
I am trying to follow this page to install the PTVS addon, downloading the first link from the table:

http://pytools.codeplex.com/wikipage?title=PTVS%20Installation

But, when running the msi installer, I get an error saying that VS 2013 must be installed:

Image

Obviously, I have MSVS 2013 Express Desktop installed already. How can I add the PTVS to the current installation?


UPDATE: I realized that I need to download 2.1Beta instead. So, I went on and downloaded it. Unfortunately, it now tells me that my version of MSVS is not supported. Any idea?
Coordinator
Jun 24 at 10:56 PM
VS 2013 Update 2 is required in order to install PTVS on the Express SKUs.
http://www.microsoft.com/en-us/download/details.aspx?id=42666
Coordinator
Jun 25 at 12:15 AM
You'll also need to use the PTVS 2.1 Beta release, since 2.0 did not have support for Express.
Jul 12 at 2:43 PM
Zooba wrote:
You'll also need to use the PTVS 2.1 Beta release, since 2.0 did not have support for Express.
Good god, I was nearly tearing my hair out as to why I wasn't able to get PTVS working on my Express for Desktop. Either I am truly blind or this little detail is nowhere to be found in PTVS home and downloads pages.
Coordinator
Jul 12 at 5:29 PM
keeperbs - curious: did you follow the Installation instructions on the Documentation tab, or just went for it from the Downloads page? if the latter, i'm wondering if we should put a link from the Download page to the Installation instructions...

https://pytools.codeplex.com/wikipage?title=PTVS%20Installation

see where it says:

I don’t have VS installed and want the Free PTVS+VS Version!

Install your preferred edition:
  • VS Express 2013 for Web
  • VS Express 2013 for Desktop
Install VS 2013 Update 2

Install PTVS 2.1 Beta 2 [note: it’s Beta]
Jul 12 at 5:36 PM
Edited Jul 12 at 6:32 PM
@Ptools, what is missing in the installation page is more elaboration on the "I already have Visual Studio and just want to install PTVS!" row. I believe many downloaders just want to extend their current VS/VS Express installation with Python support. You should clarify that Express requires the 2.1 Beta pack, and that VS Update 2 is mandatory before downloading 2.1 Beta.