No intellisense or source control

Jan 5 at 9:10 PM
I'm having some issues with PTVS that are making me want to throw this laptop out the window and move back to Mac. If some kind soul could help, I'd appreciate it!

I've had PTVS working with the free integrated shell but some issues (like no intellisense) made me decide to remove it and VS and try a reinstall. Since then I've had these problems:
  1. I can't seem to add source control to my projects. Previously I'd had VS setup with GitHub which was a really elegant and easy-to-use solution. Now the option does not appear when making a new solution and various walkthroughs I've found on the net all tell me to either add via the File menu or do other weird and wonderful things - none of which work.
  2. Intellisense is not working. There is no auto-completion or pop-up of available functions/methods. I've tried resetting settings (and got this wonderful dialog box below) to no avail. I've checked that the settings for auto-complete are set in Tools > Options, but still no intellisense.
Image

Any help would be much appreciated. I''ll give this another couple hours or I'm off to Ubuntu and PyDev!
Coordinator
Jan 5 at 9:20 PM
That's quite a deadline to throw out there on a Sunday... rest assured that we're here to help, and we can get in touch with the VS team if it's a problem with that (rather than PTVS itself). It looks like you probably need to repair the VS install, either with the Repair option or uninstall/reinstall.

You're on Windows 7, but I cannot tell which version of VS you have. Is it the latest 2013 shell? Did you use our integrated installer or install the three parts separately? When you previously had source control working, was it with this installation or was it another time completely?
Jan 5 at 9:38 PM
Zooba,

Haha, I can give it a few more hours...spread over a few days! :)

I was previously using the PTVS Integrated 2013 all-in-one installer which had my source control setup but no intellisense. I tried uninstalling and reinstalling and then I had no source control options or intellisense. I uninstalled and decided to install VS Isolated, Integrated and then PTVS standalone. But still no intellisense or source control.

To be honest I'm a bit lost so if you have any suggestions, do let me know!

P.S Other than this, PTVS is fantastic!
Jan 6 at 9:50 AM
I'm a complete nubie to this too. However, have you clicked the "Refresh DB" in the Python Environments window? You won't get intellisense until you do.

View->Other Windows->Python Environments

You'll probably see "Completion DB needs refresh" click the 'Refresh DB' button.
Coordinator
Jan 6 at 3:51 PM
It sounds like you went along the right path, but may not have completely uninstalled everything before the reinstall. Our integrated installer is just an installer - unfortunately VS makes it very hard to reliably uninstall, so it falls on the user to go through and remove what they don't want. If not for the Import/Export error, I'd say not to bother, but that error looks like VS is completely broken somehow.

My suggestion is to go for a complete uninstall, including wiping the C:\Program Files (x86)\Microsoft Visual Studio 12.0 folder (once you've uninstalled everything related to VS) and the Software\Microsoft\VisualStudio\12.0[_Config] registry keys in both HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE. You can reinstall each of the three pieces individually or use the integrated installer - it shouldn't make any difference.

As for source control, we have some limitations in the integrated version (because the VS Shell doesn't include all the features of VS) and this may extend to source control, though you should be able to get third-party extensions from the VS gallery as substitutes. There are certainly Git extensions available, but I don't think the support is baked into the Shell.

SirWeej's suggestion is exactly right if you're missing IntelliSense for just a few modules, but doesn't really apply if you don't even see the popup window. Can you remember which of these was your original issue? It's rare for IntelliSense to completely disappear after it's been working - normally that only happens for failed installations.
Jan 6 at 5:55 PM
SirWeej, yes - tried this last night a few times. No joy.

Zooba, I will try that on my machine, thanks. I definitely had GitHub support in VS but I can't recall if this was the shell or the free version of VS? I use a paid for version at work but at home use the free Express version. What version could I have been using? It was really neat!
Coordinator
Jan 6 at 6:41 PM
It may have been in the Express edition, which means that you can't use it with PTVS right now because we can't install into Express. Which languages were you working with?
Jan 6 at 7:05 PM
Zooba wrote:
My suggestion is to go for a complete uninstall, including wiping the C:\Program Files (x86)\Microsoft Visual Studio 12.0 folder (once you've uninstalled everything related to VS) and the Software\Microsoft\VisualStudio\12.0[_Config] registry keys in both HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE. You can reinstall each of the three pieces individually or use the integrated installer - it shouldn't make any difference.
Ok, uninstalled as you suggested and installed with the PTVS with Shell. No auto-completion. I can hit ctrl + space and get a list, but no intellisense. Any ideas?

Also, I was using Visual Studio before, with Python and PTVS with Git. Maybe I was using 2012?
Jan 6 at 9:12 PM
I decided to install PTVS on my desktop box that I've never programmed on. Installed fine, prompted me for a restart (my laptop didn't) and once restarted it did a further PTVS install. However, no intellisense. Am I missing something painfully obvious? I had to reinstall VS on a work machine today and intellisense worked out of the box for C# and PTVS!
Coordinator
Jan 6 at 9:26 PM
It certainly doesn't sound like you're missing anything obvious. On one of the machines that aren't working, can you click on Tools->Python Tools->Diagnostic Info and email it to ptvshelp@microsoft.com (or upload it somewhere public and link it here, but it may contain paths of personal folders, etc.).

If the menu is missing entirely then something has gone wrong at install, and the next step will be to dive into our install directory and check out the files that are there - feel free to skip ahead if you want, the dir /s/b output is what I'll be interested in.

The restart during setup will have been for .NET 4.5.1, so no need to worry about that.
Jan 7 at 7:01 AM
Zooba, I sent the diagnostic information over this morning to ptvs@microsoft.com.
Coordinator
Jan 7 at 7:14 AM
ajm - it should be ptvshelp@microsoft.com...
Coordinator
Jan 7 at 4:03 PM
Thanks, I've had a look. There doesn't seem to be anything especially wrong, though the most recent DB regenerations are a bit strange - they think you've removed more modules than you have available to remove. I suspect that either the completion DB or your Python install has become corrupted.

One folder I forgot to ask you to delete is C:\Users\<your name>\AppData\Local\Python Tools. This is where we keep the generated databases. If somehow they've become corrupt in the last few weeks then removing and regenerating them will correct that. There's no need to reinstall anything, though you'll probably need to close VS while you delete it.

If Python 2.7 is corrupt, you should be able to just use the Repair option in their installer. Otherwise, go ahead and uninstall it, delete its directory and reinstall.
Jan 7 at 7:43 PM
Hmm, this is odd. On my laptop if I go to C:\Users\ there is only an Administrator and a Public folder. There isn't my username. I wondering if I have some sort of duff Windows install here? If I go to the Start menu my name appears and lets me navigate to Documents, etc but I did notice that when I try and save my files, say when using Chrome or something, I don't have My Documents listed in the save dialog. My background isn't in Windows so this might be normal, but something does feel a bit off. I'll follow your instructions on my desktop machine and report back.

I also forgot to mention that I have reinstalled Python a few times, tried versions 2.7.7 and 3.3.2. I also manually removed the Python27 folder from the C drive.

Again, thanks for the help.
Jan 7 at 9:04 PM
I removed the Python Tools folder on my desktop, repaired the Python install and removed and reinstalled PTVS. The DB refreshed but still no auto-complete. Again, I can ctrl+space and get it but nothing appears automatically.
Coordinator
Jan 8 at 1:36 AM
Oh, you can get it when you press Ctrl+Space? What about after import or a period?

We don't pop up the list after every character, if that's what you're expecting. There's a feature request for that somewhere, but there's also a third-party extension on the Visual Studio Gallery that does it too (on my phone, so I don't have the link handy - search it for Python).

Is this the only thing wrong? Sorry for not realizing what you were saying sooner.
Jan 8 at 4:43 PM
Import and dot operators were not working before - but they are now!

I think was partly something to do with the completion db and also my own misunderstanding.

Thanks a bunch, that appears to have sorted it. Now I can continue with development! :)