How to make PTVS generate django 1.6 project/app?

Editor
Dec 20, 2013 at 1:47 AM
I'm using python 2.7 and django 1.6. However, PTVS generates the project/app according to django 1.4. I believe this is because the default "References" being "Django 1.4".
How I can change it to "Django 1.6"? I tried "Add Referrence->Web Platform Installer" but it seems only having "django 1.4".
Thanks
Nov 28, 2014 at 10:38 AM
maybe, this answer is to late.

i just found a way to change the requirement, so, the problem solved.

https://pytools.codeplex.com/discussions/573415
Coordinator
Nov 28, 2014 at 4:14 PM
Sorry we missed this originally, I guess most of us were on holiday at the time.

The reference to Django 1.4 only matters for cloud service deployment when you don't deploy a virtual environment, and in that case your requirements.txt file will take precedence (though it wouldn't have before PTVS 2.1).

As for the project layout, h2ojile's link shows that we just have a fixed layout based on what Django 1.4 did, and we tweak it every now and then for compatibility with newer versions. If you want to use Django to generate the initial layout, the best way is to do that first and then make a New Project From Existing Code.