Python 3.3.2 won't install the Python.exe file?

Oct 19, 2013 at 1:51 AM
I was programming on visual studio using python tools (already had python 3.3.2 installed) and coding was running fine. I closed it and came back around an hour later and when I tried to run it I was presented with the error, 'Interpreter "C:\Python33\python.exe" does not exist.'

I checked the Python33 folder and it indeed no longer exists. I tried uninstalling and installing 3 times with various options to no avail.

Thanks for your time


Exact window that pops up while attempting to run my .py code in Visual Studio: Python Tools for Visual Studio 'Interpreter "C:\Python33\python.exe" does not exist.'

It's not a problem with the code, it's a problem with Python. In the Python33 folder there is no python.exe or pythonw.exe so it won't run.
Coordinator
Oct 19, 2013 at 2:05 AM
Have you tried repairing the Python install? via Control Panel -> Programs & Features.

If Python doesn't show up in the list of installed programs at all, then you probably need to reinstall it.
Oct 19, 2013 at 2:30 AM
As I previously stated, I already tried this.
Coordinator
Oct 19, 2013 at 2:38 AM
I'm sorry, I misinterpreted it as you reinstalling PTVS.

If reinstalling Python doesn't give you the files, then I see only two possibilities here: either your Python installer is corrupt (which seems unlikely, as it should be able to detect that and display an error during the install), or you have something on your system which is silently removing those binaries as soon as they are copied.

I suspect that you may be falling victim to an overly aggressive antivirus - do you have anything like that (other than the Windows built-in one)?

I also wonder what happens if you try installing it to a path other than the default. If my hypothesis is correct, it still won't work, but you might be able to see the binaries land on the disk before they're cleaned up if you have the installation folder opened in Explorer while the installer is running...