Pykinect: Unable to get video with skeleton to display

Aug 2, 2013 at 3:04 PM
I am unable to get the video with skeleton to display. I was able to get the basic "Hello World" program to work where the skeleton coordinates are printed.

from pykinect import nui
with nui.Runtime() as kinect:
kinect.skeleton_engine.enabled = True
while True:
    frame = kinect.skeleton_engine.get_next_frame()
    for skeleton in frame.SkeletonData:
        if skeleton.eTrackingState == nui.SkeletonTrackingState.TRACKED:
            print skeleton
However, when I try to run PyGameDemo.py sample the only thing I get is a blank terminal. I can't seem to get the live video stream to run at all. Any ideas? Thanks!!
Coordinator
Aug 2, 2013 at 10:37 PM
which version of the kinect sdk are you using?
Aug 5, 2013 at 5:17 PM
I am running the Kinect for Windows SDK v1.7. After I wrote the question I was able to get the code to work in the Spyder IDE, but can't get it to work in Visual Studio 2013. I am very new to VS so this has something to do with it.
Coordinator
Aug 5, 2013 at 7:05 PM
Was it just debugging which wasn't working for you? Were you able to run w/ Ctrl-F5 (launching w/o debugging)?

If they were both not working, then my immediate guess would be that we're not running against the right Python interpreter. You can try going into project properties and set the interpreter for the project to the same one Spyder was using.
Aug 6, 2013 at 3:29 PM
Thank you! I was launching with debugging. Ctrl+F5 did the trick.