This project has moved and is read-only. For the latest updates, please go here.

"Requested registry access is not allowed" when creating new Python project

Aug 30, 2011 at 1:26 PM

anyone encountered with the same problem? I don't even how to start tracing the problem!

Aug 30, 2011 at 3:49 PM

Thanks for reporting this.  I haven't seen a repro here, but there are two options:

  1. If you want to help us troubleshoot the problem, you could get procmon from the sysinternals site and do a trace just as you encounter the error. If you want to try this let me know and I'll help you get it set up.
  2. If you just want to be unblocked, it might work to run Visual Studio as an administrator once. (If this doesn't work, then I'd be extremely interested to have you do the procmon trace.)
Aug 30, 2011 at 4:28 PM

OK, thanks for pointing me to procmon, actually I used it before but didn't think of it at the first time.

I've tried to run devenv.exe with Administrator user but it didn't work, and procmon reveals that when devenv.exe reads HKCR\.pyproj it got ACCESS DENIED.

When I check the permission of that key with regedit.exe with administrator permission I even can't change its permission. weird. But seems it's not Python Tools' problem. I'll post an update after I got some progress.

Aug 30, 2011 at 4:45 PM

Solved the problem with regedit taking its ownership. Seems something strange happened during installation, because it has a entry for 'msiserver' but without any permission.