Aug 13, 2011 at 9:53 AM

I have 'Microsoft Visual Studio 10.0' entry in 'Program Files', with 'Microsoft Visual C++ 2010 Express - ENU' under it, working properly.

PythonToolsInstaller.msi refuses to install, with the message 'Visual Studio 2010 must be installed..."

What gives?

Aug 13, 2011 at 7:30 PM

Hi; PTVS doesn't install into Express editions because Express editions don't support add-ins. However, you can install the integrated shell ( and then install PTVS into the integrated shell; or you can upgrade to VS Pro.

Aug 13, 2011 at 11:19 PM

I just updated the Installation guide to make it more explicit re no VS Express.