This project has moved and is read-only. For the latest updates, please go here.


Jun 7, 2011 at 3:41 PM

I am not (totally) sure if this is PTVS or a SCIPY for .NET issue so I’ll cross-post.


So here is the sequence of events.


  1. installed IronPython 2.7 (PythonContext on .NET 4.0.30319.225)
  2. installed Python 2.6.6
  3. installed vs2010 with Microsoft
    1. Version 10.0.40219.1 SP1Rel
    2. Microsoft .NET Framework
    3. Version 4.0.30319 SP1Rel
    4. Installed Version: Professional
    5. Microsoft Office Developer Tools
    6. Microsoft Visual Basic 2010
    7. Microsoft Visual C# 2010
    8. Microsoft Visual C++ 2010
    9. Microsoft Visual Studio 2010 Team Explorer
    10. Crystal Reports Templates for Microsoft Visual Studio 2010
    11. Hotfix for Microsoft Visual Studio 2010 Professional - ENU (KB2455033)   KB2455033
    12. Microsoft Visual Studio 2010 Professional - ENU Service Pack 1 (KB983509)   KB983509
    13. Python Tools for Visual Studio   1.0
    14. PythonHpcSupport   1.0
    15. PythonProfiling   1.0
    16. ReplWindow   1.0
    17. Visual Studio Repl Window
  4. Proceeded with PTVS installation (to get to status shown above)


At that point,


Creating both IronPython and Python console projects functioned properly. Creating a C# project that calls an IronPython function also worked as expected.


Then installed numpy-2.0.0b2-1 for .Net.


Invoking ipy with the X:Frames, numpy and scipy function properly in the ipy console.


But in Visual Studio, trying tor create an IronPython console will produce the following error:


Exception has been thrown by the target of an invocation


I strongly suspect that this is because the –X:Frames is not used by PTVS but I have not been able to change this behavior (interpreter option is grayed out).


I can think of trying a few workarounds but I’d rather not resort to those just yet if this can be fixed in the “OFFICIAL” distribution.

Jun 13, 2011 at 10:04 PM


I can confirm I have exactly same issue.

This happened only after installing the file and downloading and installing the associated numpy and scipy files included in the package.

Basically I can't create any of the IronPython project anymore. (File/ New / Project).

The regular Python projects (not ironpython) still works.

PythonContext on .NET 4.0.30319.1

I have the same error message: Exception has been thrown by the target of an invocation

I also confirm the following: Invoking ipy with the X:Frames, numpy and scipy function properly in the ipy console.

I uninstalled and reinstalled IronPython 2.7 without the ironpkg file, after deleting the numpy and scipy files and i could create new project again. After reinstalling ironpkg same issue as before.

Any help would be greatly appreciated,




Jun 14, 2011 at 12:43 AM

Hi, thanks both of you for reporting this issue. This is a combination of bug + missing feature.

We will have a fix checked in this week which will allow X:Frames to work correctly in the Visual Studio IronPython console. If you don't want to build the fix yourself from source, this fix will also be included in RC1, which is coming soon.

Aug 9, 2011 at 5:17 PM
Edited Aug 9, 2011 at 5:23 PM



I must confirm that this issue is still present in my RC2 installation, which is out since Aug 1. Did I miss some configuration option somewhere?



An edit: for anyone as blind as I am :  

Tools - Options -  Python Tools - Interactive Windows - Interpretter options : Set to -X:Frames

did help...