This project has moved and is read-only. For the latest updates, please go here.

PTV with Django and appengine

Apr 18, 2011 at 1:48 AM

i wonder if anyone setup a DJango with appengine and had it working with PTV , 

i haven't tried yet but i will give it a try i think in the next week , please drop in for any suggestions.

May 1, 2011 at 3:34 PM

+1. i tried (w/o django). Ctrl+F5 works. but i think the debugger is buggy. when i do F5 i get following output (after waiting for a while). then, when i launch the browser and try to hit a url, the page never loads. it appears the python code never gets a chance to execute. and sometimes VS crashed. i am using VS 2010 shell + ptvs

WARNING  2011-05-01 14:25:38,460] No ssl package found. urlfetch will not be able to validate SSL certificates.INFO     2011-05-01 14:25:41,503] Server:     2011-05-01 14:25:41,565] Checking for updates to the SDK.
INFO     2011-05-01 14:25:43,625] The SDK is up to date.INFO     2011-05-01 14:25:45,559] Connecting to SQLite database '' with file 'c:\\users\\appdata\\local\\temp\\dev_appserver.rdbms'
WARNING  2011-05-01 14:25:45,762] Could not initialize images API; you are likely missing the Python "PIL" module. ImportError: No modulenamed _imagingINFO     2011-05-01 14:25:46,012] Running application myapp on port 8080: http://localhost:8080


i have set my startup file (alt+enter->general) to be c:\program files\google\google_appengine\

launch mode (alt+enter->debug) is standard python launcher

May 12, 2011 at 11:47 PM
Edited Jul 18, 2011 at 9:33 PM

Hi. this is not a bug. The output you are seeing contains only WARNING and INFO messages, but no errors.

I implemented the "helloworld" application from

File -> New -> Project -> Python Application

  • Name: helloworld
  • Location: c:\temp

Rename -> and cut and paste Google's sample code

Right click on project helloworld -> Add -> New Item -> Text File

  • Name: app.yaml

Cut/paste Goole's sample app.yaml code

Right click on project helloworld -> Properties

  • Debug -> Search Paths -> C:\google_appengine\;C:\Temp\helloworld\
  • Debug -> Command Line Arguments -> c:/temp/helloworld
  • General -> Startup File: c:/google_appengine/
  • General -> Working Directory: c:\temp\helloworld
  • General -> Interpreter: Python 2.5

Put breakpoint on line 2 of

Debug -> Start Debugging

Open Browser, navigate to http://localhost:8080

You will break on an unhandled ZipImportError. The first time you hit the exception in the debugger, click "Break". Open up Debug->Exceptions, click "Add". Select "Python Exception".  Paste in the exact name of the exception you want to ignore, namely google.appengine.dist.py_zipimport.ZipImportError and click "OK". Make sure this exception is unchecked in the Exceptions dialog box (it defaults to checked), and click "OK".  In the debugger, do Debug->Continue (or press F5). The project should begin executing and skip breaking at all the other places the ZipImportError is thrown.

--> Breakpoint is hit in

--> Press the "Go" arrow and execution continues

Result in Browser: "Hello, World!"

Result in console window:


WARNING  2011-05-12 22:39:52,773] No ssl package found. urlfetch will not be able to validate SSL certificates.
INFO     2011-05-12 22:39:53,117] Server:
WARNING  2011-05-12 22:39:53,148] Could not read datastore data from c:\users\johncos\appdata\local\temp\dev_appserver.datastore
INFO     2011-05-12 22:39:53,148] Connecting to SQLite database '' with file 'c:\\users\\johncos\\appdata\\local\\temp\\dev_appserver.rdbms'
WARNING  2011-05-12 22:39:53,148] Could not initialize images API; you are likely missing the Python "PIL" module. ImportError: No module named _imaging
INFO     2011-05-12 22:39:53,210] Running application helloworld on port 8080: http://localhost:8080
INFO     2011-05-12 22:40:13,512] "GET / HTTP/1.1" 200 -



  1. I don't have an ssl package installed, and I don't have PIL installed, which explains warnings 1 and 3.
  2. I haven't made an app that attempts to write to the appserver datastore, which is why there is no datastore under c:\users\johncos\appdata\local\temp
May 14, 2011 at 6:45 PM

Hi Joxn,

Thanks for your investigation. Glad you did not encounter any issue. Before I revisit this issue again, I wanted to know are there any html/css/javascript/jquery tools for visual studio. see this link:

I am basically interested in using ptvs for develop google app engine apps. However, ptvs only provides the tools to do server side programming. To do client side programming, I need html/css/javascript/jquery integration.

I am using the vs shell. is there any package similar to ptvs that can be installed to provide the html/css/javascript/jquery support I need?

May 24, 2011 at 10:34 PM

I don't know if there's a package for the VS Shell similar to PTVS that does this. There isn't one provided by Microsoft, because it would compete with Visual Studio Professional.